Prevenire i reindirizzamento del browser su Android (e iOS) -- security campo e browser campo e chrome-for-android campo android imparentato Problema

Preventing browser redirects on Android (and iOS)



6
vote

problema

italiano

Sembra che ci sia un problema che si verifica con le app del browser mobile su Android e iPhone vengono reindirizzate ai siti pubblicitari. Questo sta interrompendo l'esperienza di navigazione.

Il problema:

    .
  • Un utente visita un sito Web sul proprio telefono in un browser corrente e aggiornato come Chrome per Android o Firefox per Android e AD è visualizzato
  • L'annuncio provoca un reindirizzamento dal sito Web attualmente visualizzato a spaces.slimpots.com
  • Il server Slimspots sembra controllare se JavaScript è attivo e quindi reindirizza ad un altro annuncio, ad esempio una pagina web della concorrenza

Molti utenti hanno riportato questo, sia sul forum del prodotto Chrome che sui forum di Apple, (collegamenti nella pastebina sottostante) ma nessuno sembra capire cosa sta verificando effettivamente. Le persone stanno facendo una fabbrica inutile reset sui loro telefoni e si lamentano per vari webmaster sugli annunci sui loro forum.

Il comportamento può essere replicato in un browser desktop modificando l'utente-agente in un Nexus 4 e ricaricando un thread del forum su un sito Web (ad esempio XDA-Sviluppatori) fino a quando viene visualizzata un annuncio offensivo.

Dal momento che non riesco a creare più di due collegamenti qui senza guadagnare più reputazione, puoi trovare alcuni contenuti utili in questo Pastebin .

Qualcuno può fornire consigli su come sopprimere questi reindirizzamenti, senza ricorrere a un browser non azionario?

Originale inglese

There seems to be an issue occurring with mobile browser apps on Android and iPhone being redirected to advertising sites. This is interrupting the browsing experience.

The problem:

  • A user visits a website on their phone in a current and up-to-date browser such as Chrome for Android or Firefox for Android, and a mobile ad is displayed
  • The ad causes a redirect from the currently displayed website to spaces.slimspots.com
  • The slimspots server seems to check if Javascript is active and then redirects to another ad, such as a competition webpage

Many users have reported this, both on the Chrome product forum and on the Apple forums, (links in the pastebin below) but nobody seems to understand what is actually occurring. People are doing unnecessary factory resets on their phones and complaining to various webmasters about the ads on their forums.

The behavior can be replicated in a desktop browser by changing the User-Agent to a Nexus 4 and reloading a forum thread on a website (eg. xda-developers) until an offending ad appears.

Since I can't create more than two links here without gaining more reputation, you can find some useful content in this pastebin.

Can anybody provide advice on how to suppress these redirects, without resorting to a non-stock browser?

        

elenco di risposte

3
 
vote

Prima di tutto: deve essere segnalato questo tipo di pubblicità

.

Qualcuno può fornire consigli su come eliminare questi redirect, senza ricorrendo a un non-browser magazzino?

Sembra che usano un bug in JavaScript. Forse riferire al fornitore di annunci o del proprietario app per il blocco.

Come riprodurre il problema:

    .
  • Se si utilizza il browser preinstallato in Android, sito di annunci apre "Google Play Store" e vi mostrerà ogni volta una diversa applicazione.

Come posso sandbox del contenuto non attendibile dall'utente presentato JavaScript?

 

First of all: This kind of advertising should be reported!

Can anybody provide advice on how to suppress these redirects, without resorting to a non-stock browser?

It looks like they use a bug in JavaScript. Maybe report to ad provider or app owner for blocking.

How to reproduce this issue:

  • If you use the preinstalled browser in Android, the ad site opens "Google Play Store" and show you each time a different App.

How can I sandbox untrusted user-submitted JavaScript content?

 
 
   
   
1
 
vote

Mi ero quasi garanzia che né è il router infettati da malware, né ha la sua impostazione DNS stata modificata / violato.

Ho eliminato il problema di siti in cui abbiamo un router MikroTik utilizzando un filtro di protocollo di livello 7 come mostrato di seguito. Questo non aiuta i dispositivi al largo della rete WiFi (ovviamente), ma almeno dà loro un po 'di tregua quando sono collegati a casa e / o reti WiFi di lavoro.

In primo luogo, creare la definizione di protocollo:

  /ip firewall layer7-protocol add comment="Frigging javascript redirects on chrome browsers"      name=Javascript_Redirect      regexp="^.+(spaces.slimspot.com|mostawesomeoffers.com).*$"   

Ora, per filtrare in realtà questo traffico fuori

  /ip firewall filter add action=drop chain=forward comment=     "Block and log Javascript_Redirect L7 Protocol" layer7-protocol=     Javascript_Redirect log=yes log-prefix=JSredirect_   

Altri firewall che hanno una capacità di filtraggio Layer 7 potrebbe anche bloccare questi reindirizzamenti in modo simile.

 

I'd almost guarantee that neither is the router infected with malware nor has its DNS setting been changed/hacked.

I have eliminated this issue on sites where we have a MikroTik router by using a Layer 7 protocol filter as shown below. This doesn't help the devices off the WiFi network (obviously) but at least gives them some reprieve when they are connected to home and/or work WiFi networks.

Firstly, create the protocol definition:

/ip firewall layer7-protocol add comment="Frigging javascript redirects on chrome browsers" \     name=Javascript_Redirect \     regexp="^.+(spaces.slimspot.com|mostawesomeoffers.com).*\$" 

Now, to actually filter this traffic out

/ip firewall filter add action=drop chain=forward comment=\     "Block and log Javascript_Redirect L7 Protocol" layer7-protocol=\     Javascript_Redirect log=yes log-prefix=JSredirect_ 

Other firewalls that have Layer 7 filtering capacity could also block these redirects in a similar way.

 
 
0
 
vote

Non c'è niente di sbagliato con il telefono o il browser, è il router wifi. E 'infettato da malware - le impostazioni DNS vengono modificate per reindirizzamento ai siti di malware.

    .
  1. provare a visitare 192.168.1.1 in modalità wireless - non sarà in grado di farlo.

  2. router Collegare tramite cavo LAN

  3. Hard resettare il router

  4. configurazione manuale del router (consultare il proprio fornitore di servizi se non si hanno i dettagli a portata di mano)

  5. (Importante) Modificare la password del router di amministrazione della "password" default a qualcos'altro. È così che il malware entrato in possesso del router.

 

There's nothing wrong with the phone or browser, it's the wifi router. It's infected with malware - the DNS settings are changed to redirect to the malware sites.

  1. Try visiting 192.168.1.1 wirelessly - you won't be able to.

  2. Connect router via LAN cable

  3. Hard reset the router

  4. Manually setup the router (consult your service provider if you don't have the details handy)

  5. (Important) Change the router admin password from the default "password" to something else. That's how the malware got hold of router.

 
 
0
 
vote

Installa blocco annuncio più browser, risolverà il problema in Chrome pure. Questa è l'unica cosa che ha funzionato per me

 

Install Ad block plus browser, it will solve the issue in Chrome as well. This is the only thing that worked for me

 
 
 
 
0
 
vote

Non so se sarebbe stato di alcun aiuto per manifesti precedenti, ma ho trovato una soluzione per il reindirizzamento numerose stavo affrontando mentre semplicemente cercando di guardare video. È sufficiente disabilitare Javascript e abilitare manualmente solo i siti web che si desidera accedere. In questo modo sto ottenendo soltanto una scheda aperta mi reindirizzamento ad una pagina vuota facilmente chiuso, invece di decine di pagina consecutivi mi chiede se voglio davvero lasciare o dirmi il mio telefono è infetto. E 'un po' di tempo per aggiungere eccezioni per i siti web che visito che l'uso di JavaScript, ma se siete come infastidito da me su reindirizzamenti è un piccolo prezzo che notevolmente migliorato il mio conforto navigazione. Basta ricordare che se una pagina non si sta caricando probabilmente per aggiungere un'eccezione nelle impostazioni del sito JavaScript.

Solo così si sa io sono in nessun posto vicino un esperto in computer, in modo questa è solo una soluzione che ho provato quando ho letto qui che si trattava di un bug exploit in JavaScript.

 

I don't know if it would be of any help for previous posters, but I found a workaround for the numerous redirect I was facing while simply trying to watch videos. You simply disable JavaScript and enable manually only the websites you want to access to. That way I am only getting one opened tab redirecting me to a blank page easily closed instead of dozens of consecutive page asking me if I really want to leave or telling me my phone is infected. It is somewhat time consuming to add exceptions for websites I visit that use JavaScript, but if you are as annoyed as me about redirections it's a small price that greatly improved my browsing comfort. Just remember that if a page isn't loading you probably have to add an exception in your JavaScript site settings.

Just so you know I am nowhere near an expert in computer so this is only a solution I tried when I read here that it was a bug exploit in JavaScript.

 
 

Domande correlate

3  Come faccio a disattivare lo zoom a fuoco l'immissione di testo?  ( How do i disable zooming on text input focus ) 
So che ci sono alcuni trucchi per lo zoom disabilita quando si effettua una pagina web, ma come faccio a disabilitare lo zoom a fuoco sul mio dispositivo? H...

1  Disabilitare lo scorrimento regolare in Android Chrome 73  ( Disable smooth scrolling in android chrome 73 ) 
C'è un modo per disabilitare lo scorrimento regolare in Android Chrome 73.x? Sembra che ora sia abilitato per tutti i siti per impostazione predefinita e impo...

10  Come scorrere velocemente su Chrome Mobile  ( How to fast scroll on chrome mobile ) 
Ho appena installato Chrome Mobile sulla mia nota di galassia (ICS, CM9) e mentre ha questa bella interfaccia simile alla carta, non ho trovato come sfogliare...

18  Come aggiornare una pagina Web in Chrome (analogico Ctrl + F5) su un dispositivo senza pulsante di menu?  ( How to refresh a web page in chrome ctrlf5 analogue on a device without menu ) 
Ho un dispositivo Android Nexus 7 con 4.2.2 e browser Chrome. Come si può eseguire un aggiornamento approfondito di una pagina Web - Analogico di Ctrl + F...

5  video incorporati di YouTube hanno suono, ma non il video  ( Embedded youtube videos have sound but no video ) 
Ogni volta che mi imbatto in una pagina con un video e premere play YouTube incorporato allora il suono sarà sentito ma il video sarà vuoto (schermo nero). ...

26  Perché il nuovo aggiornamento Chrome desidera il permesso di utilizzare la mia fotocamera e la registrazione audio?  ( Why does the new chrome update want the permission to use my camera and audio re ) 
Seriamente afferma che può specificamente che può utilizzare la fotocamera e la registrazione audio in qualsiasi momento che vuole, se lo desidero o meno . P...

4  C'è un modo per caricare automaticamente il contenuto insicuro nel browser Chrome per Android?  ( Is there a way to automatically load insecure content in chrome browser for andr ) 
Simile a questa domanda ma per lo spazio mobile ... https://superUser.com/questions/487748/How- to-consentito-cromato-browser-to-load-insicure-content C'...

0  è impossibile conoscere l'indirizzo MAC WiFi di un telefono Android tramite un link?  ( Is it impossible to know a wifi mac address of an android phone via a link ) 
C'è qualcuno che dubito che usa il mio telefono rubato quindi voglio fare in modo che il telefono cellulare che usa è mio o no conoscendo l'indirizzo Wifi MAC...

0  Reindirizzamento cromato per Messenger su Samsung Mobile  ( Chrome redirects to messenger on samsung mobile ) 
Ho ricevuto avvisi di reindirizzamento sul mio browser di Samsung Google Chrome con un link a Messenger. Una volta ho installato Messenger ma non l'ho mai usa...

17  Come può un bookmarklet da aggiungere sul mobile Chrome senza copiare e incollare?  ( How can a bookmarklet be added on mobile chrome without copying and pasting ) 
Sul mio telefono Android, come può un utente aggiungere un bookmarklet ai miei segnalibri Chrome, senza la necessità di utilizzare un altro dispositivo, e ...




© 2022 www.domanda.top All Rights Reserved. Domanda e risposta a casa tutti i diritti riservati